Crimson Editor::Help Topics::Commands


File Menu

New – Create a new document
Open – Open an existing document
Open Template... – Open an existing document template
Close – Close the active document
Close All – Close all open files
Save – Save the active document
Save As... – Save the active document with a new name
Save All – Save all the active documents
Print... – Print the active document
Print Preview – Display full pages
Print Setup... – Change the printer and printing options
• FTP ››
     - Open Remote... – Open an existing document from ftp server
     - Save As Remote... – Save the active document with a new name
     - FTP Settings... – Set the ftp accounts
• Recent Files ››
     - N. Recent File – Open this document
Exit – Quit the application; prompts to save documents


Edit Menu

Undo – Undo the last action
Redo – Redo the previously undone action
Cut – Cut the selection and put it on the Clipboard
Copy – Copy the selection and put it on the Clipboard
Paste – Insert Clipboard contents
Delete – Delete the selection
• Append ››
     - Cut Append – Cut the selection and append it to the Clipboard
     - Copy Append – Copy the selection and append it to the Clipboard
• Select ››
     - Select All – Select the entire document
     - Select Line – Select the current line
     - Select Word – Select the current word
     - Select Block – Select the current block enclosed with brackets
• Change Case ››
     - Upper Case – Convert the selected text to upper case
     - Lower Case – Convert the selected text to lower case
     - Capitalize – Capitalize the selected text
     - Invert Case – Invert the case of the selected text
• Insert ››
     - Insert Date – Insert current date
     - Insert Time – Insert current time
     - Insert File... – Insert a file into current cursor position
• Advanced ››
     - Increase Indent – Increase the indentation of current line or selected block
     - Decrease Indent – Decrease the indentation of current line or selected block
     - Delete Line – Delete current line
     - Duplicate Line – Duplicate current line
     - Delete Word – Delete current word
     - Delete Prev Word – Delete previous word
     - Delete to End of Line – Delete to end of line
     - Join Lines – Join two lines
     - Split Line – Split current line
     - Make Comment – Add comment delimiter in the beginning of the lines
     - Release Comment – Remote comment delimiter in the beginning of the lines


Search Menu

Find... – Find the specified text
Replace... – Replace the specified text with different text
Find Next – Find the next matching text
Find Prev – Find the previous matching text
Find in Files... – Search for a string in multiple files
Go To... – Move to a specified location
Toggle Bookmark – Set or clear bookmark at current line
Next Bookmark – Go to next bookmark position
Prev Bookmark – Go to previous bookmark position
• Advanced ››
     - Prev Editing Position – Go to previous editing position
     - Pairs Begin Position – Go to matching brace beginning position
     - Pairs End Position – Go to matching brace end position


View Menu

• Toolbars/Window ››
     - Toolbar – Show or hide the toolbar
     - Status Bar – Show or hide the status bar
     - File Selection Tab – Show or hide the file tab
     - Directory Window – Show or hide the directory window
     - Output Window – Show or hide the output window
Word Wrap – Toggle word wrap
Spell Check – Enbale spell check
Line Numbers – Show line numbers
Column Markers... – Show or hide column markers
Screen Fonts ›› – Select the screen font
Printer Fonts ›› – Select the printer font
Line Spacing ›› – Select the line spacing
Tab Size ›› – Select the tab size
Set Colors... – Configure screen color settings
• Others ››
     - Show Tab Characters – Show tab characters
     - Show Line Break – Show line break


Document Menu

• Syntax Type ››
     - Automatic – Detect document syntax type automatically
     - Plain Text – Set the current document as plain text
     - Customize... – Customize document syntax types
Reload Document – Reload the active document
Lock Document – Lock the active document from changes
• File Format ››
     - DOS Format (CR/LF) – Set the active document to the DOS file format
     - Unix Format (LF only) – Set the active document to the Unix file format
     - Mac Format (CR only) – Set the active document to the Mac file format
• Encoding Type ››
     - ANSI Encoding – Set the active document to ANSI encoding
     - Unicode Encoding – Set the active document to Unicode encoding
• Tabs & Spaces ››
     - Convert Tabs to Spaces – Convert tabs to spaces
     - Convert Spaces to Tabs – Convert spaces to tabs
     - Leading Spaces to Tabs – Convert leading spaces to tabs
     - Remove Trailing Spaces – Remove trailing white spaces
Summary... – Show the active document summary


Tools Menu

Preferences... – Set the preferences
Evaluate Line – Evaluate the current expression
MS-DOS Shell – Execute MS-DOS shell
View in Browser – View the active document in default browser
Configure User Tools... – Add or remove user defined commands


Macros Menu

Begin Recording... – Start key stroke recording
End Recording – Stop key stroke recording
Replay Macro – Play back the key stroke recording
Configure Macros... – Configure macros


Window Menu

Last Visited – Switch to the last visited window
Next Window – Switch to the next window
Prev Window – Switch back to the previous window
Cascade – Arrange windows so they overlap
Tile Horizontally – Arrange windows as horizontal, non-overlapping tiles
Tile Vertically – Arrange windows as vertical, non-overlapping tiles


Help Menu

Help Topics... – List help topics
Visit Homepage... – Visit crimson editor homepage
Feedback... – Send feedback to developer
About Crimson Editor... – Display program information, version number and copyright

 


File > New File Menu


Use this command to create a new empty document.


File > Open File Menu


Use this command to open an existing document in a new window.

Crimson Editor displays the File Open dialog box so that you can choose documents to edit. You can open multiple documents at once.

Files can also be opened by dragging them from the Window Explorer into Crimson Editor's window and dropping them.

Use File Tab to switch among the multiple open documents.


File > Open Template File Menu


Use this command to open an existing document template in a new window.

Crimson Editor displays the Open Template dialog box so that you can choose a document template to open.

Document templates are plain text files saved in 'template' sub directory of Crimson Editor install directory. You can make your own document templates, just copy your custom document template files into this directory.


File > Close File Menu


Use this command to close window containing the active document.

Crimson Editor suggests to save changes to your document before you close it. If you close a document without saving, you lose all changes made since the last time you saved it.


File > Close All File Menu


Use this command to close all windows opened in Crimson Editor.

Crimson Editor suggests to save changes to your document before you close it. If you close a document without saving, you lose all changes made since the last time you saved it.


File > Save File Menu


Use this command to save the active document to its current name and directory.

When you save a document for the first time, Crimson Editor displays the Save As dialog box so that you can name your document.


File > Save As File Menu


Use this command to save the active document with different name.

Crimson Editor displays the Save As dialog box so that you can name your document.


File > Save All File Menu


Use this command to save all the documents opened in Crimson Editor.

When you save a document for the first time, Crimson Editor displays the Save As dialog box so that you can name your document.


File > Print File Menu


Use this command to print the active document.

Crimson Editor displays the Print dialog box, where you can specify the destination printer, printer setup options, and the range of pages to be printed.


File > Print Preview File Menu


Use this command to display the active document as it would appear when printed.


File > Print Setup File Menu


Use this command to select a active printer and specify various printing options.


File > FTP > Open Remote File Menu


Use this command to open files from a remote FTP server.

If you run Save command with remote file, the changes you made will be saved directly to the file on the FTP server.


File > FTP > Save As Remote File Menu


Use this command to save the current document to a FTP server.

If you run Save command with remote file, the changes you made will be saved directly to the file on the FTP server.


File > FTP > FTP Settings File Menu


Use this command to set the FTP account information.

Crimson Editor displays the FTP Settings dialog box, where you can specify the FTP server, user name, password, etc.


File > N. Recent File File Menu


Use this command to open documents you closed recently.


File > Exit File Menu


Use this command to quit Crimson Editor.

Crimson Editor prompts you to save documents if there are changes unsaved.


Edit > Undo Edit Menu


Use this command to reverse the last editing action.


Edit > Redo Edit Menu


Use this command to reverse the last undon action.


Edit > Cut Edit Menu


Use this command to remove selected text from the document and put it on the clipboard.


Edit > Copy Edit Menu


Use this command to copy selected text onto the clipboard.


Edit > Paste Edit Menu


Use this command to insert a copy of the clipboard contents at the current caret position.


Edit > Delete Edit Menu


Use this command to delete current selection of the active document.


Edit > Append > Cut Append Edit Menu


Use this command to cut and append selected text onto the clipboard.


Edit > Append > Copy Append Edit Menu


Use this command to copy and append selected text onto the clipboard.


Edit > Select > Select All Edit Menu


Use this command to select the entire document.


Edit > Select > Select Line Edit Menu


Use this command to select the line at current cursor position.


Edit > Select > Select Word Edit Menu


Use this command to select the word at current cursor position.


Edit > Select > Select Block Edit Menu


Use this command to select the block enclosed with brackets.


Edit > Change Case > Upper Case Edit Menu


Use this command to convert the selected text to upper case.


Edit > Change Case > Lower Case Edit Menu


Use this command to convert the selected text to lower case.


Edit > Change Case > Capitalize Edit Menu


Use this command to capitalize the selected text.


Edit > Change Case > Invert Case Edit Menu


Use this command to convert the case of selected text to opposite case.


Edit > Insert > Insert Date Edit Menu


Use this command to insert current date into the current cursor position.


Edit > Insert > Insert Time Edit Menu


Use this command to insert current time into the current cursor position.


Edit > Insert > Insert File Edit Menu


Use this command to insert contents of a file into current cursor position.


Edit > Advanced > Increase Indent Edit Menu


Use this command to increase the indentation of the selected text.


Edit > Advanced > Decrease Indent Edit Menu


Use this command to decrease the indentation of the selected text.


Edit > Advanced > Delete Line Edit Menu


Use this command to delete the line at the current cursor position.


Edit > Advanced > Duplicate Line Edit Menu


Use this command to duplicate the line at the current cursor position.


Edit > Advanced > Delete Word Edit Menu


Use this command to delete current word at the current cursor position.


Edit > Advanced > Delete Prev Word Edit Menu


Use this command to delete previous word at the current cursor position.


Edit > Advanced > Delete to End of Line Edit Menu


Use this command to delete to end of line at the current cursor position.


Edit > Advanced > Join Lines Edit Menu


Use this command to join two consecutive lines into one long line.


Edit > Advanced > Split Line Edit Menu


Use this command to split the line at the current cursor position.


Edit > Advanced > Make Comment Edit Menu


Use this command to insert line comment delimeter at the beginning of the line.


Edit > Advanced > Release Comment Edit Menu


Use this command to delete line comment delimiter at the beginning of the line.


Search > Find Search Menu


Use this command to search specific text in current document.


Search > Replace Search Menu


Use this command to search specific text in current document and replace it with different text.


Search > Find Next Search Menu


Use this command to search the next occurrence of the selected text.


Search > Find Prev Search Menu


Use this command to search the previous occurence of the selected text.


Search > Find in Files Search Menu


Use this command to search specific text in multiple files.


Search > Go To Search Menu


Use this command to go to specific line in current document.


Search > Toggle Bookmark Search Menu


Use this command to set or clear a bookmark at current line.


Search > Next Bookmark Search Menu


Use this command to search for next bookmark position.


Search > Prev Bookmark Search Menu


Use this command to search for previous bookmark position.


Search > Advanced > Prev Editing Position Search Menu


Use this command to get back to previous editing position.


Search > Advanced > Pairs Begin Position Search Menu


Use this command to go to current pairs beginning position.


Search > Advanced > Pairs End Position Search Menu


Use this command to go to current pairs end position.


View > Toolbars/Window > Toolbar View Menu


Use this command to show or hide the Toolbar, which contains buttons for most common commands of the Crimson Editor.


View > Toolbars/Window > Status Bar View Menu


Use this command to show or hide the Status Bar, which displays short description of the action to be executed by the selected menu item.


View > Toolbars/Window > File Selection Tab View Menu


Use this command to show or hide the File Selection Tab, which offers easy access to all open documents.


View > Toolbars/Window > Directory Window View Menu


Use this command to show or hide the Directory Window, which displays list of files in the current working directory.


View > Toolbars/Window > Output Window View Menu


Use this command to show or hide the Output Window, which displays the output of user tools.


View > Word Wrap View Menu


Use this command to turn on or off the word-wrapping feature.


View > Spell Check View Menu


Use this command to enable the spell check feature in current document. This command shows red zigzag line under wrong spelled words.


View > Line Numbers View Menu


Use this command to show or hide line numbers in the active document.


View > Column Markers View Menu


Use this command to show or hide vertical dotted lines at the specified position.


View > Screen Fonts View Menu


Use this command to set font settings or select the screen font.


View > Printer Fonts View Menu


Use this command to set font settings or select the printer font.


View > Line Spacing View Menu


Use this command to set the spacing between two adjacent lines.


View > Tab Size View Menu


Use this command to set the tab size used in documents


View > Set Colors View Menu


Use this command to set color settings.


View > Others > Show Tab Characters View Menu


Use this command to show or hide tab characters in documents.


View > Others > Show Line Break View Menu


Use this command to show or hide the line break symbol in documents.


Document > Syntax Type > Automatic Document Menu


Use this command to detect document syntax type automatically.


Document > Syntax Type > Plain Text Document Menu


Use this command to set the current document as plain text.


Document > Syntax Type > Customize Document Menu


Use this command to customize document syntax types.


Document > Reload Document Document Menu


Use this command to reload the active document.


Document > Lock Document Document Menu


Use this command to lock the active document from changes.


Document > File Format > DOS Format (CR/LF) Document Menu


Use this command to set the active document to the DOS file format.


Document > File Format > Unix Format (LF only) Document Menu


Use this command to set the active document to the Unix file format.


Document > File Format > Mac Format (CR only) Document Menu


Use this command to set the active document to the Mac file format.


Document > Encoding Type > ANSI Encoding Document Menu


Use this command to set the active document to ANSI encoding.


Document > Encoding Type > Unicode Encoding Document Menu


Use this command to set the active document to Unicode encoding.


Document > Tabs & Spaces > Convert Tabs to Spaces Document Menu


Use this command to convert tabs in the active document to spaces.


Document > Tabs & Spaces > Convert Spaces to Tabs Document Menu


Use this command to convert spaces in the active document to tabs.


Document > Tabs & Spaces > Leading Spaces to Tabs Document Menu


Use this command to convert leading spaces in the active document to tabs.


Document > Tabs & Spaces > Remove Trailing Spaces Document Menu


Use this command to remove trailing white spaces in the active document.


Document > Summary Document Menu


Use this command to show the active document summary.


Tools > Preferences Tools Menu


Use this command to set your preferences of Crimson Editor. You can find more information in the Preferences help page.


Tools > Evaluate Line Tools Menu


Use this command to evaluate a expression in Crimson Editor. You can find more information in the Built-in Calculator help page.


Tools > MS-DOS Shell Tools Menu


Use this command to open a MS-DOS shell.


Tools > View in Browser Tools Menu


Use this command to open the active document in the default web browser of your system.


Tools > Configure User Tools Tools Menu


Use this command to configure the user tools. User tool is user-defined application that Crimson Editor launches. You can find more information in the Preferences help page.


Macros > Begin Recording Macros Menu


Use this command to begin recording the keystrokes. Recorded keystrokes can be played back using Replay Macro command.


Macros > End Recording Macros Menu


Use this command to end recording the keystrokes. Recorded keystrokes can be played back using Replay Macro command.


Macros > Replay Macro Macros Menu


Use this command to play back the recorded keystrokes.


Macros > Configure Macros Macros Menu


Use this command to configure the recorded keystrokes. You can find more information in the Preferences help page.


Window > Last Visited Window Menu


Use this command or press Ctrl+Tab to switch to the last visited window.


Window > Next Window Window Menu


Use this command to switch to the next window.


Window > Prev Window Window Menu


Use this command to switch to the previous window.


Window > Cascade Window Menu


Use this command to arrange multiple opened windows in an overlapped fashion.


Window > Tile Horizontally Window Menu


Use this command to arrange multiple opened windows as horizontal, non-overlapping tiles.


Window > Tile Vertically Window Menu


Use this command to arrange multiple opened windows as vertical, non-overlapping tiles.


Help > Help Topics Help Menu


Use this command to display this Help contents.


Help > Visit Homepage Help Menu


Use this command to browse Crimson Editor homepage. http://www.crimsoneditor.com/


Help > Feedback Help Menu


Use this command to send any bug report, suggestion, question and comment to the author. crimsonware@yahoo.com


Help > About Crimson Editor Help Menu


Use this command to display program information, version number and copyright.


Copyright © 1999-2003 by Ingyu Kang, All rights reserved.